Author Topic: Fuel sender problem!  (Read 359 times)

8683jb

  • Hero Member
  • *****
  • Posts: 504
Fuel sender problem!
« on: October 24, 2019, 08:03:43 PM »
I installed one of the fuel senders and something ain’t right. The float arm hits the baffle and won’t go below about half full, and the float itself is smack in the middle of the opening so there’s no way for the fuel screen to fit. I thought these were the right senders, but I guess not. Are there different senders for different tanks? I appreciate any help!

Jon














« Last Edit: October 24, 2019, 08:09:24 PM by 8683jb »
'42 Autocar M2A1

MVPA member

8683jb

  • Hero Member
  • *****
  • Posts: 504
Re: Fuel sender problem!
« Reply #1 on: October 25, 2019, 10:28:30 AM »
Problem solved. The sender extends too deep into the tank and is for a different application. Thanks Jeff/Beerman.

Jon
'42 Autocar M2A1

MVPA member

yd328

  • Hero Member
  • *****
  • Posts: 613
Re: Fuel sender problem!
« Reply #2 on: October 25, 2019, 12:34:29 PM »
Glad you found it. Now I have to go and double check my senders.

Gary

pyropanzer

  • Newbie
  • *
  • Posts: 8
Re: Fuel sender problem!
« Reply #3 on: October 25, 2019, 03:40:35 PM »
I got mine from Hebding, the were wrong and did not fit, like a a good bit of things I bought from him over the years.  Like yours they were to long.  I modified them, shorten the shaft, and they work fine now.  Anthony

8683jb

  • Hero Member
  • *****
  • Posts: 504
Re: Fuel sender problem!
« Reply #4 on: October 25, 2019, 04:06:13 PM »
I thought I'd do the same thing if I can't find the right ones at a reasonable price. It looks easy enough to shorten everybody and just offset the float arm to clear the strainer. Thanks for the help Anthony.

Jon
'42 Autocar M2A1

MVPA member

pyropanzer

  • Newbie
  • *
  • Posts: 8
Re: Fuel sender problem!
« Reply #5 on: October 25, 2019, 07:03:42 PM »
I think I cut the float wire and reshaped it to fit.  Best I can remember.  Anthony

8683jb

  • Hero Member
  • *****
  • Posts: 504
Re: Fuel sender problem!
« Reply #6 on: October 25, 2019, 07:51:50 PM »
I'd probably do the same. I'm pretty sure if I tried to re-solder the float to the wire I'd have two float halves and a loose wire.
'42 Autocar M2A1

MVPA member

emptyhead

  • Sr. Member
  • ****
  • Posts: 425
Re: Fuel sender problem!
« Reply #7 on: October 27, 2019, 03:01:59 PM »
I picked my sending units up from david yamulla in pa. Picked up two for the price of Gary’s one.

8683jb

  • Hero Member
  • *****
  • Posts: 504
Re: Fuel sender problem!
« Reply #8 on: October 27, 2019, 05:41:39 PM »
Thanks David. I already started cutting these ones down to the proper lengths. I appreciate the info.

Jon
'42 Autocar M2A1

MVPA member